A veces, debido a restricciones de proyecto, he tenido que usar una versión de eclipse más antigua de lo que tocaba. Un día, intentando añadir mi tomcat 9 a eclipse, ví que no tenía compatibilidad ya que se realiza una validación por el número de versión. (Un poco fuera lugar, dado que para la versión 8.0.0 tampoco te deja añadir un tomcat 8.x)

Podemos solventar esto parcheando el fichero catalina.jar incluido en la carpeta lib de nuestro Tomcat. Para ello editaremos el fichero ServerInfo.properties y modificaremos la versión.

  • Jar a parchear: <Ruta de Tomcat>/lib/catalina.jar
  • Ruta del fichero a parchear: <Ruta del Jar>/org/apache/catalina/util/ServerInfo.properties

Modificaremos el contenido del fichero tal que quede así:

Una vez modificado y guardado ya podremos añadirlo sin problemas.

 

Añadir un servidor tomcat en eclipse más alto de la versión soportada
Etiquetado en:        

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *